Brave Ads is experiencing a partial outage. We are currently investigating.
Incident Report for Brave Software
Resolved
This incident has been resolved.
Posted May 21, 2021 - 14:08 UTC
Investigating
Brave Ads is experiencing a partial outage. We are currently investigating.
Posted May 20, 2021 - 20:43 UTC
This incident affected: Brave Rewards (Brave Ads).